Our News

MetaTrader 4 Desktop and Android Terminals Won’t Support the Old Versions

 – 2019.02.22
Dear clients!

We want to inform you that from March 1, 2019, the MetaTrader 4 desktop terminals below 1118 build and Android MetaTrader 4 terminals below 1104 build will not be supported anymore. This means that such terminals will not be able to connect to the JustForex trading servers. Please update your trading terminals to the latest version.

Best regards,
JustForex team